Вставка видео с YouTube одной строкой (1.10.3)

2543
- Всегда волнуюсь, когда красная полоска на YouTube догоняет серую. (с)

Плагин заменяет ссылку на видео с YouTube кодом плеера.

""


Работает в блогах, в комментариях, на стене, на форуме.


Как это выглядит

Устанавливается как обычный плагин:
Скачать, распаковать, залить, установить из админки, включить, настроить размер плеера.
Вывод рекламного блока в статье (v1.10.3)
Комментарии (45)
Сергей Егоров 11 ноября 2013 в 11:41 +1
Класс! Пойду устанавливать.
lokanaft 11 ноября 2013 в 11:43 +1
Код PHP:
  1. public function install(){ return parent::install(); }
  2. public function upgrade(){ return parent::upgrade(); }
Это можно не писать - потомок наследует методы предка, если они не переопределены.
И лучше так писать: <br /> v
Maximov 11 ноября 2013 в 14:54 +1
Возможно Вы правы, но на сегодня именно такая запись в плагинах от "InstantCMS Tea" в последней версии движка.
lokanaft 11 ноября 2013 в 17:09 +1
Там это сделано чисто для наглядности.
sergioss 11 ноября 2013 в 12:08 +1
Версия для 1.10.3 ?
Сергей Егоров 11 ноября 2013 в 12:30 0
laugh Нет, человек будет делать для устаревшей версии v
nedoriko 11 ноября 2013 в 12:37 +5
А зря смеешься. Такой вариант совсем не исключен в наше время.
К примеру начал человек делать для старой версии. И пока делал новую версию выпустили. И что ему теперь бросать работу на пол пути? Разумеется он доделает для старой ну а после уж возмется за новую. Разве не логично?
Сергей Егоров 11 ноября 2013 в 20:10 0
Но ведь 1.10.3 давно вышла)
akhasanov 11 ноября 2013 в 13:32 0
Какие версии поддерживаются? На 1.10.1 будет работать?
Maximov 11 ноября 2013 в 14:55 +8
Насчет версии.

Делал под 1.10.3. должна работать под любой 1.10.x.
Прошу прощения, что не указал сразу, впредь буду более внимательным.
Запись подправил.

Но вот что странно. Посмотрел соседей на первой странице в блоге, у записей также нет указаний под какую версию и ни одного вопроса про это. Тут же, пока комментариев про версию больше чем про работу плагина. scratch
Saw 11 ноября 2013 в 17:33 0
Указал бы версию сразу и всё joke А придумка отличная! +
eoleg 11 ноября 2013 в 19:31 0
+
Maximov:
Посмотрел соседей на первой странице в блоге, у записей также нет указаний под какую версию и ни одного вопроса про это.
Возможно это звонок! smile
shaman888 11 ноября 2013 в 20:47 +5
это нужно в стандартную сборку добавлять. однозначно полезная штука
alex 12 ноября 2013 в 00:19 +2
Плюсую... Очень полезная штука. Автор молодец!
BELIEVER 12 ноября 2013 в 12:20 0
Кто небудь попробовал 1.10.1 ?
Sonat 12 ноября 2013 в 13:21 +1
Пробовал, работает.
Юрий (Pizza Celentano) 12 ноября 2013 в 15:33 +1
Спасибо огромное за полезность выложенную вами
farmacevtum 12 ноября 2013 в 19:23 +1
+1 поставил! спасибо автору! плагин классный!
Су-27 13 ноября 2013 в 08:14 +1
Удобно и практично - спасибо и плюсик
Славик 13 ноября 2013 в 23:06 0
Странно у меня не работает к сожалению...
Maximov 14 ноября 2013 в 11:34 +2
Список наводящих вопросов для поиска причины отправил в ЛС
Славик 14 ноября 2013 в 21:38 0
Ответил в личке
Славик 14 ноября 2013 в 21:59 +1
Понял я ошибку свою, я использовал вставку Код видео (Youtube/Rutube)
а не просто вставить ссылку в сообщение, я видимо не внимателен... прошу прощения scratch
Patriot 14 ноября 2013 в 01:37 +1
Спасибо! На 1.10.1 полет нормальный )
Викторыч 14 ноября 2013 в 10:38 0
Версия 1.10.3. Не работает. Вернее, не совсем работает. Бежит мелкий снег по кадру, как в японском фильме ужасов и надпись на английском: "Произошла ошибка. Пожалуйста, повторите попытку позже...": Вставляю через кнопку "Ссылка". Если вставлять через "Видео" обычным кодом, все показывает нормально, там только обрезанное http: надо добавлять.

""
Изображение уменьшено. Щелкните, чтобы увидеть оригинал.
Maximov 14 ноября 2013 в 11:32 +3
Предлагаю пообщаться в ЛС чтобы найти причину.
Викторыч 14 ноября 2013 в 12:35 0
ок, отписал все как есть, вечером, после работы, поработаю над ошибками )
Викторыч 14 ноября 2013 в 17:50 +1
Все проверил, все, что надо, работает как часы. Maximov, большое спасибо за помощь!
Капитан 16 ноября 2013 в 15:05 0
Простая и удобная вещь! Спасибо автору! Даже на изрядно переделанной системе 1.10.1 все работает отлично! +
Dorimen 30 ноября 2013 в 21:35 0
А для 1.9 можно?
BELIEVER 6 декабря 2013 в 11:00 0
а ты попробуй может и будет работать
Dorimen 23 января 2014 в 12:15 0
Проверил на 1.9 - все хорошо работает.
BELIEVER 6 декабря 2013 в 11:01 0
у меня 1.10.1 работает прекрасно но и вообще пора обнавится
Evgeny123 6 декабря 2013 в 23:48 0
На 10.1 работает?
BELIEVER 7 декабря 2013 в 10:11 0
да работает
Андрей 13 декабря 2013 в 19:05 +1
надо добавить, чтоб ссылка вида http://www.youtube.com/watch?feature=player_embedded&v=XXXXX тоже заменялась)
щас поколдую... но я не программер
Dorimen 27 января 2014 в 13:19 0
В версии 1.9 в блогах нормально заменяет, а на форуме нет.
Max 20 февраля 2014 в 09:25 0
На 1.10.3 работает. При редактировании сообщения остается только ссылка.
Principal 12 июля 2014 в 22:32 +1
Все отлично работало, после обновления до 1.10.4 перестало sad только сейчас заметил :(
Principal 12 июля 2014 в 22:32 +1
Все отлично работало, после обновления до 1.10.4 перестало sad только сейчас заметил :(
AmDmKo 26 октября 2014 в 11:37 0
Перестал фурычить плагин! на версии 1.10.4
kviv 27 октября 2014 в 13:12 0
И на версии 1.10.3 не идет :/
banachi 5 февраля 2015 в 13:50 0
На версии 1.10.5 не работает((
Карен М. 10 апреля 2015 в 03:36 0
В 1.10.6 тоже не работает. Жаль. facepalm
Шадринец 12 апреля 2015 в 08:38 0
Уважаемые Инстановцы., Подскажите решение можно ли сделать чтоб в ленте активности тоже заменялись ссылки на ролики? А то както получается не красиво одни ссылки непонятные,
Например: Вася пишет на стене и ссылка в виде текста.

Спасибо.