Настройка VDS

для работы InstantMaps

 
Посетитель
small user social cms
Сообщений: 90
В связи с новогодней загруженностью техподдержки компонента решил задать вопрос тут. Задача такая, практически стандартный VDS нужно настроить для работы с компонентом InstantMaps. Что сделано:
1. Установил Zend так
2. Установил IonCube так
Результат - и /maps и /servtest.php - белый экран scratch
php -v
php -m
Всем откликнувшимся большое человеческое спасибо))
Посетитель
small user social cms
МедальПочетный донор проекта
Сообщений: 55
попробуйте PHP 5.2
Реклама
cms
Посетитель
small user social cms
Сообщений: 90
OlegSaf:

попробуйте PHP 5.2
Олег спасибо за совет, но не вариант к сожалению. Не хочу дауингрейдить, думаю есть более изящное решение))
Вообще в требованиях к компоненту Zend не указан, хотя при его отсутствии компонент прямо требует зенд оптимайзер не ниже версии 3.0.0... Что то мне подсказывает, что IonCube встал не так, ибо компонент подарков (by forlord) также отказались работать.
Посетитель
small user social cms
Сообщений: 90
В этой теме пишут, что даже на 5.4 работает без проблем, но вот что точно должно быть установлено на серваке нет нигде. А ведь любой серьезный проект на Instant ждет одинаковая судьба: hosting-->VDS-->dedicated
Посетитель
small user social cms
Медаль
Сообщений: 287
fotpod:
1. Установил Zend так
2. Установил IonCube так
Как вы модули установили совершенно не важно, чобы понять в чем проблема нужны логи ошибок на вашем vps. Посмотрите что пишет в логах. Иначе мы не телепаты.
Посетитель
small user social cms
Сообщений: 90
Код PHP:
  1. mod_fcgid: stderr: PHP Fatal error: Incompatible file format: The encoded file has format major ID 3, whereas the Loader expects 4 in /var/www/clients/web/components/maps/model.php on line 0, referer: http://site.ru/
Редактировалось: 1 раз (Последний: 26 декабря 2012 в 01:13)
Посетитель
small user social cms
Сообщений: 90
Полистал Гугл по данной ошибке, с английским плохо, так понял, что советуют перекодировать файл под PHP 5.3..... Странно, ведь в требованиях к компоненту указана именно 5.3 hoho
Посетитель
small user social cms
МедальПочетный донор проектаАвторитет форумаКубок зрительских симпатий
Сообщений: 2470
Все правильно, попросите r2 прислать под 5.3
fotpod:
на 5.4 работает без проблем
работает но не все, не ставьте 5.4, ошибки есть и нужно перекодировать под 5.4, у меня крон не отрабатывает, сейчас устанавливаю ubuntu 12.04, в ней рнр 5.3
Раньше РАЙ был везде - РАЙсовет, РАЙком, РАЙсобес...., а сейчас везде АДминистрации!
Не надо давать людям советы. Каждый должен лохануться самостоятельно!
Любишь в продакшн, люби и баги починить!
Посетитель
small user social cms
Сообщений: 90
Понял, куда уж 5.4 если на 5.3 неделю не могу организовать полноценную работу...
Да я вроде бы все расписал в техподдержку, сразу оговорился, что PHP 5.3, сутки ждал вопроса о версиях InstantCMS и InstantMaps, ответил мол 1.9 и 2.2, и пошел сюда ибо тяжело в таком "замедленном чате" (1 вопрос в сутки) общаться zst
Соответственно компонент подарков тоже нужно просить под 5.3? Там по логам та же фигня.
Посетитель
small user social cms
МедальПочетный донор проектаАвторитет форумаКубок зрительских симпатий
Сообщений: 2470
fotpod:
Соответственно компонент подарков тоже нужно просить под 5.3?
Скорее всего forlord уже сделал, нужно спрашивать
под 5.3 вроде все нормально работает так что переходите.
Раньше РАЙ был везде - РАЙсовет, РАЙком, РАЙсобес...., а сейчас везде АДминистрации!
Не надо давать людям советы. Каждый должен лохануться самостоятельно!
Любишь в продакшн, люби и баги починить!
Посетитель
small user social cms
МедальАвторитет форумаКубок зрительских симпатийПочетный донор проекта
Сообщений: 2928
fotpod:
1. Установил Zend
2. Установил IonCube
Я сколько не пробовал - такая смесь всегда ошибки вызывала в работе сервера на php 5.3...
Без зенда все работает отлично!
В общем понял что нужно юзать или IonCube, или Zend по отдельности! Zend на php 5.2

ps: fotpod, кстати по ссылке установки Zend Guard Loader не пробовал - вернее ставил, но все скопом) нужно попробовать Loader поставить отдельно, спасибо за ссылку...

Есть тут кто то, кто юзает на php 5.3 IonCube вместе с Zend? как правильно Zend втулить?) чтоб ошибки не создавал.
Посетитель
small user social cms
Сообщений: 90
Получается Zend Guard Loader вообще не нужен для работы компонента на PHP 5.3?
Можно его смело снести?
Посетитель
small user social cms
Медаль
Сообщений: 395
Премиумные компоненты на IonCube перевели все, так что если он вам не нужен, я думаю, можно и снести.
Посетитель
small user social cms
Сообщений: 90
Отлично, осталось дождаться от R2 версию под 5.3 smoke
Кстати компонент подарков Forlord обещал после праздничков hoho
Посетитель
small user social cms
МедальАвторитет форумаКубок зрительских симпатийПочетный донор проекта
Сообщений: 2928
Роман:
я думаю, можно и снести.
если не используете другие скрипты закрытые Zend-ом)

Мне этот гавеный Zend очень нужен, но приходится жертвовать из-за перевода компонентов на IonCube(

ps: как я ненавижу эти зенды и кубы, слов просто нет, хотя и понимаю что пользу большую многим приносят...
В начало страницы
Предыдущая темаСледующая тема Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.