Не работает капча при регистрации

 
Посетитель
small user social cms
Сообщений: 21
При миграции сайта с версии 1.9 на 1.10 проблем с регистрацией не было, позже обновил до последней версии 1.10.1 и заметил что регистрации прекратились, попробовал пройти тестовую регистрации и увидел что капча не загружается.

Поискал на форуме похожие темы, нашёл вот эту ноп роблему решить не получилось. все права выставлены на папки и подпапки инклуд. Даже заменил сам компонент регистрации по новой, перезалил по новой папку инклуд, то есть переустановка не помогла. Не знаю где копать. одно решение за комментировать валидацию капчи и с самой формы её удалить, но повалит спам. Прошу помочь. Вот сам сайт http://dostlar.com.ua/
Кто к нам... с чем... тот от того... и того!
Посетитель
small user social cms
Сообщений: 21
никто не поможет? не подскажет?
Кто к нам... с чем... тот от того... и того!
Реклама
cms
Модератор
small user social cms
МедальАвторитет форумаКубок зрительских симпатий
Сообщений: 1097
попробуйте папку includes/codegen заменить от версии 1.10
Посетитель
small user social cms
Сообщений: 21
К сожалению и это не сработало, не знаю что и делать. Пробовал отключать проверку (валидацию капчи) но хлынул спам, что пришлось несколько десятков профелей спамных удалять. ивернуть всё на место, но теперь реальные пользователи не могут регистрироваться
Кто к нам... с чем... тот от того... и того!
Посетитель
small user social cms
МедальАвторитет форумаКубок зрительских симпатий
Сообщений: 3026
Leo, Похоже, что у Вас в шаблоне нет места для вывода капчи. Движок то Вы обновили, а шаблон нет. Данную тему обсуждали http://instantcms.ru/blogs/instantlab/shablon-octopus-v-1-10.html попробуйте заменить com_registration_login.tpl от дефолтного шаблона
Посетитель
small user social cms
Сообщений: 21
Volgomarket, тут что-то другое, так как у меня шаблон свой собственный. ну даже если это и так, то скрипт должен генерировать капчу по этому адресу
http://dostlar.com.ua/includes/codegen/cms_codegen.php

можете сами проверить на своём проекте, просто подставте свой домен. например так:

http://kavsvadba.ru/includes/codegen/cms_codegen.php (проект тоже на Instant`e)
Кто к нам... с чем... тот от того... и того!
Модератор
small user social cms
МедальАвторитет форумаКубок зрительских симпатий
Сообщений: 1097
PrazdNik:
попробуйте папку includes/codegen заменить от версии 1.10
Leo:
К сожалению и это не сработало, не знаю что и делать.
А вы кеш чистили после замены?
Редактировалось: 1 раз (Последний: 28 марта 2013 в 12:07)
Посетитель
small user social cms
Сообщений: 21
Само сабой разумеется, всякий раз когда делаю манипуляции то чищу папку кеш от записей. Списался со службой тех поддержки сообщили что:
отображается ошибка HTTP 500, которая относится к ошибкам веб-сервера. Рекомендую Вам ознакомиться с лог-файлами веб-сервера.

но что мне это даст я так и не понял
Кто к нам... с чем... тот от того... и того!
Модератор
small user social cms
МедальАвторитет форумаКубок зрительских симпатий
Сообщений: 1097
Leo:
позже обновил до последней версии 1.10.1 и заметил что регистрации прекратились
Я бы на Вашем месте вернулся на версию 1.10. Затем обновлялся бы до 1.10.1, заменяя по одной папке или файлу и после каждой замены проверял что изменилось, появилась регистация или нет. Таким образом найдете причину.
Посетитель
small user social cms
Сообщений: 21
проблему решили установкой функции на сервер

проблема была связана с вызовом библиотечной функции из скрипта imagecreatefrompng(): Для работы данной функции был необходим пакет php_gd, который отсутствовал в системе.

скрипт работает )))
Кто к нам... с чем... тот от того... и того!
Модератор
small user social cms
МедальАвторитет форумаКубок зрительских симпатий
Сообщений: 1097
Leo:
проблему решили установкой функции на сервер
Вот и отлично)
В начало страницы
Предыдущая темаСледующая тема Перейти на форум: