Модуль раздел статей.

 
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1545
Здравствуйте.Подскажите решение пожалуйста.Система 1.10.3.Модуль "разделы статей" не правильно выводит список вложенных разделов.Базу смотрел, там всё правильно,проверку деревьев делал, всё нормально.А в модуле всё через одно место.
Посетитель
small user social cms
МедальАвторитет форумаКубок зрительских симпатий
Сообщений: 1981
Скриншот неправильного выведения в студию.
NOP
Реклама
cms
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1545
Извините,а что покажет скриншот?Это надо и скрин админки-категории, и т.д.Суть в том,что подкатегории не в тех категориях показывает+некоторые категории оказываются в подкатегории.Вот и всё.В админки всё правильно расположенно.В базе правильно,а в модуле нет.Две системы.Одна на локалке,другая на хосте.И там и там тоже самое.
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1545
P.S.Причём,если по отдельности разделы выводить, то всё правильно выводиться, а если ставить "Все разделы",то нет.
Посетитель
small user social cms
МедальАвторитет форумаКубок зрительских симпатий
Сообщений: 1981
Видите, в правильно заданном вопросе содержится половина ответа. Я сразу заподозрил, что у вас проблема в tpl-файлах, а скриншот помог бы мне в этом убедится. Вы хорошо описали проблему, но скриншот помог бы мне в этом убедиться быстрее. Смотрите файлы com_catalog_index.tpl и com_catalog_cats.tpl сперва в текущем шаблоне, а потом в дефолтном. Возможно, они битые, или поковырялся в них кто.
NOP
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1545
Спасибо, за совет,но не помогло.Заменил эти файлы на дефолтовые и ничего.И это полбеды.В конце концов без этого модуля можно и обойтись как нибудь.Но с разделами вообще что то не то.Я понимаю если модуль барахлит возможно и сам где то что то не так сделал.Но вот есть раздел.В нём четыре подраздела.Общее кол-во статей 31.Каждый подраздел выводит список статей с анонсами и картинкой.В определёный момент времени один из подразделов перестаёт выводить картинки.В самих статьях они на месте.Как такое может быть?
К тому же модуль "последние материалы" настроенный на вывод статей всего раздела выводит на две статьи меньше.Статьи все на месте.Короче незнаю,что делать.В пору стреляться.
Посетитель
small user social cms
МедальПочетный донор проектаКубок зрительских симпатийАвторитет форумаПочетный донор проекта
Сообщений: 2823
Чистая инсталяция, добавлено парочку категорий:
Модуль раздел статей.

в разделах и в модуле:
Модуль раздел статей.
Украинский для инстант
Посетитель
small user social cms
МедальПочетный донор проектаКубок зрительских симпатийАвторитет форумаПочетный донор проекта
Сообщений: 2823
Lora:
К тому же модуль "последние материалы" настроенный на вывод статей всего раздела выводит на две статьи меньше.Статьи все на месте.Короче незнаю,что делать.В пору стреляться.
Проверьте у всех ли статей стоит галочка "показывать в новых статьях"
Украинский для инстант
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1545
У тех статей,что не выводятся все галочки стоят.Уже всё менял что можно.И ссылку,и число,и плагины все отключал,не хочет выводить их модуль,хоть убей.Заменил папки /modules ,/components/ и в корне и в шаблоне на дефолтовые не помогло.И эта 1.10.3. изначальна не хотела заводиться.Постоянно что то не то.Уже думаю 1.0.9. вернуть.Зря обновлялся.Не было вообще проблем.
Посетитель
small user social cms
МедальПочетный донор проектаКубок зрительских симпатийАвторитет форумаПочетный донор проекта
Сообщений: 2823
Lora:

Зря обновлялся.
Нет ни малейшего сомнения: эта проблема будет исправлена разработчиками
Украинский для инстант
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1545
Спасибо, Олег Васильевич я, за поддержку.Насчёт "Зря обновлялся." это я погорячился пожалуй. smile Пойду дальше "грызть".Картинки вернулись в раздел(Алиллуя! angel ).Наверное в гости ходили.Может и статьи со временем вернуться...
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1545
Возможно нашёл причину неотображения статей в модуле (пост№6).Сейчас столкнулся с такой ситуацией.Был раздел в корне, без привязки меню, со статьями.Создал для него пункт в доп.меню.Всё хорошо.Галочка в модуле меню стоит для вывода меню в данном разделе.Соответственно при открытии статьи из этого раздела меню в ней выводится.Но при переносе статьи из другого раздела в этот, меню в ней не выводится.Менял ссылку,чистил кеш.Не помогает.Возможно те статьи не выводятся по этой же причине.Проверять уже нет время,потом отпишусь.
Редактировалось: 1 раз (Последний: 2 февраля 2014 в 10:32)
Посетитель
small user social cms
МедальАвторитет форумаКубок зрительских симпатий
Сообщений: 1981
Lora, с аналогичным багом встретился только что. При настройке сайта пришлось переносить статьи из одного раздела в другой и обратно. Соответственно, пункты меню из одного меню в другое (их у меня два). В итоге напереносился - деревья исказились. На сайте и в админке разделы и статьи показаны неправильно. В админке, при проверке деревьев пишет "Дерево разделов для статей — найдены ошибки!", "Дерево меню — найдены ошибки!" Нажал кнопку "исправить выбранное", так теперь у меня в таблицах cms_menu и cms_category каша. Например, в полях NSLeft и NSRight обоих таблиц появились отрицательные значения. Сижу ломаю голову, как быть.
Редактировалось: 1 раз (Последний: 2 февраля 2014 в 11:25)
NOP
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1545
Я тоже с деревьями на днях возился.Тоже самое было.Хорошо хоть статей ещё не много.В админки сначала всё выставлял,а потом в базе всё переписал вручную.Весь изматерился.
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1545
P.S. Ещё ,если раздел с перенесённой статьёй перенести в другой раздел,то меню начинает всё правильно отображать,но появляется проблема уже с разделом.Замкнутый круг. scratch
В начало страницы
Предыдущая темаСледующая тема Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.