php 5.3 => совместимость на будущее

для сторонних разработчиков

 
Посетитель
small user social cms
Медаль
Сообщений: 865
Заметил использование некоторыми сторонними разработчиками функционала на php ограничивающими использование дополнений версией до 5.3. включительно. Например передача по ссылке &$var.

Сам движок собран корректно, так что большая просьба ко всем сторонним разработчикам давайте его не засорять подобными не совместимыми на перспективу вариантами.

всё )), всем спасибо!
Посетитель
small user social cms
МедальКубок зрительских симпатийАвторитет форума
Сообщений: 1160
Я в некоторых своих разработках использовал функцию
Код PHP:
  1. $model->selectOnly();
в php 5.3 проблем не было, но в версиях выше получал ошибку, оказывается ID там обязательно должен быть.

P.S. что бы другие не совершали моих ошибок))
Редактировалось: 1 раз (Последний: 11 сентября 2015 в 19:31)
Дополнения для InstantCMS 2 | Готовый сайт Доска объявлений
Посетитель
small user social cms
Медаль
Сообщений: 134
если $model это экземпляр класса , как метод этого класса может выдавать ошибку ? и как на это может повлиять версия php ? shock

Или в данном случае $model это что ?
Редактировалось: 1 раз (Последний: 11 сентября 2015 в 22:05)
В начало страницы
Предыдущая темаСледующая тема Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.