Проблемы с блогом клуба

Пропал блог, новые посты не добавляются.

 
Посетитель
small user social cms
МедальАвторитет форумаКубок зрительских симпатийПочетный донор проекта
Сообщений: 2758
Неожиданно обнаружил, что из блога одного клуба пропади все посты. Нет их и в базе.
Ну, думаю, ладно. Кто-то из модеров опять снес по ошибке - восстановлю из бекапа.
Но при попытке добавления нового поста вылетает ошибка 404 со странным текстом:
.
Fatal error: Call to undefined method cmsConfig::getConfig() in /var/www/******/data/www/******.ru/templates/******/special/error404.php on line 25

Метода getConfig() в классе cmsConfig нет!
Из-за чего может вылезать такая странная ошибка?

При этом с остальными клубами и блогами всё нормально.
Посетитель
small user social cms
МедальКубок зрительских симпатийПочетный донор проекта
Сообщений: 828
Насколько могу суть у вас проблема в шаблоне в частности в странице с ошибкой 404 special/error404.php скорее всего у вас старый вариант данной страницы.
Компоненты, модули, шаблоны, разработка на заказ - широкий выбор всего
Посетитель
small user social cms
МедальАвторитет форумаКубок зрительских симпатийПочетный донор проекта
Сообщений: 2758
maxisoft,
В смысле проблема с special/error404.php ?
Да, движок еще 1.9 никак не допилю до 1.10.6
Но почему вообще выбрасывает на 404 при добавлении поста в блог?

Посмотрел в админке - вообще нет такого блога! Хотя на сайте отображается и в базе есть.
Ладно, продолжу завтра...

Выяснилось, что куда-то из базы делся seolink этого блога. Всё заработало. Спасибо за помощь!
Осталось выяснить, как из админки можно стереть этот сеолинк. К базе безрукие доступа не имеют.
Редактировалось: 2 раз (Последний: 28 января 2016 в 01:17)
В начало страницы
Предыдущая темаСледующая тема Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.