неверное определение версии PHP 2.X

как такое может быть. и что с этим делать?

 
Посетитель
small user social cms
Медаль
Сообщений: 278
Здравствуйте.
Собственно, все написано в заголовке. Пробую поставить чистый дистрибутив системы 2.10. Сразу остановка прекращается. с сообщением что установлена версия 5.4.45 а требуется минимум 5.5. Одновременно с этим, в свойствах моего хостинга указано четко и понятно: Версия PHP - 5.6.36!
Что интересно, примерно месяца два назад ставил для интереса посмотреть предыдущую систему (2.9 наверное, не помню...) - никаких проблем не возникло, все встало и работает.
ПРошу, кто в курсе ситуации - поясните, как с этим быть? Мне очень нужна свежая версия системы.
Спасибо!
Посетитель
small user social cms
МедальКубок зрительских симпатийАвторитет форума
Сообщений: 1857
А если поставить 7.1 или 7.2? Должно все быстрее работать тем более.
Контент для ваших проектов. Копирайт всех видов от профессионалов. Создание и продвижение сайтов, реклама.
Реклама
cms
Посетитель
small user social cms
Медаль
Сообщений: 278
garry:

А если поставить 7.1 или 7.2? Должно все быстрее работать тем более.

К сожалению я не могу ничего поставить или изменить, так как это публичный хостинг Multihost. Никогда, за много лет, с этим хостингом не возникало ни единой проблемы.
Посетитель
small user social cms
МедальКубок зрительских симпатийАвторитет форума
Сообщений: 1857
ALreD:
К сожалению я не могу ничего поставить или изменить, так как это публичный хостинг Multihost.
Вот только что подсмотрел у них на всех тарифах можно выбрать PHP 5.2 - 7 (на выбор)
Наверняка в панеле можно переключать.
Редактировалось: 1 раз (Последний: 14 июня 2018 в 14:09)
Контент для ваших проектов. Копирайт всех видов от профессионалов. Создание и продвижение сайтов, реклама.
Посетитель
small user social cms
Сообщений: 94
Код PHP:
  1. <?php
  2. echo 'Текущая версия PHP: ' . phpversion();
  3.  
Неплохо бы средствами PHP убедиться какая у вас версия.
Посетитель
small user social cms
МедальПочетный донор проектаАвторитет форума
Сообщений: 1311
ALreD:
Одновременно с этим, в свойствах моего хостинга указано четко и понятно: Версия PHP - 5.6.36!

Создайте файл PHP инфо
http://poleshuk.ru/ispolzuem-phpinfo/
И посмотрите какая на самом деле версия PHP.

Мало ли...
По результатам к хостеру...
Посетитель
small user social cms
Медаль
Сообщений: 278
Rainbow:

ALreD:
Одновременно с этим, в свойствах моего хостинга указано четко и понятно: Версия PHP - 5.6.36!

Создайте файл PHP инфо
http://poleshuk.ru/ispolzuem-phpinfo/
И посмотрите какая на самом деле версия PHP.

Мало ли...
По результатам к хостеру...

Ха!!!Спасибо огромное! По Вашему совету сделал - и правда показывает версию PHP Version 5.4.45! Отличный ход... Реальная система и система, которую показывают в панели) Сейчас будет разговор с хостером... Мучительный для него)))
В начало страницы
Предыдущая темаСледующая тема Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.