Насколько критично использование старой версии CMS? 1.X

Купил сайт, нужно понять масштаб проблем

 
Посетитель
no avatar
Сообщений: 8
Всем привет, мне достался сайт v1.10.1 насколько критично его обновления, часто ли взламывают эту CMS? Также насколько сложен переход на более ранние версии?
Как поднять бабла - мой инструментарий;
GoPR - онлайн-конструктор сайтов ( продается).
Посетитель
no avatar
МедальАвторитет форума
Сообщений: 2776
на более ранние не стоит переходить, лучше на более поздние. взламывают не систему, а сайты. если ваш сайт сильно интересен и генерирует большие денюжки, то он становится интересен. зачастую легче взломать сервер, чем сам сайт.
Реклама
cms
Посетитель
small user social cms
МедальПочетный донор проектаАвторитет форумаКубок зрительских симпатийПочетный донор проекта
Сообщений: 1724
@gagarin:
Всем привет, мне достался сайт v1.10.1 насколько критично его обновления, часто ли взламывают эту CMS?

Обновлять конечно надо всегда если есть обновления.
Насчет взлома... Здесь скорее больше играют знания админа, чем КМС.

По статистике (уже писал раньше, не знаю где мне эти цифры попадались, но спорить вряд ли кто будет) примерно 80-90% причин взлома, это разгильдяйство и некомпетентность владельца сайта, а не уязвимость движка.

И вторая составляющая умение быстро восстановить сайт (из резервной копии или просто исправить на рабочем сайте) если все таки, что то произошло (не обязательно взлом)...

@gagarin:
часто ли взламывают эту CMS?

Что бы был именно взлом, здесь не слышал, хотя были жалобы на вирусы, но в основном как позже выяснялось по причинам администрирования (что написал выше).

Статья в тему, в принципе коротко все написано верно:
https://habr.com/post/94356/

@gagarin:
насколько сложен переход на более ранние версии?

Наверное все таки на более поздние?

Полностью зависит от самого сайта, какие дополнения были установлены, какие шаблоны.. все это надо обновлять.
Иногда довольно сложно... Иногда лучше (в некотором смысле) вообще ничего не трогать если не понимаешь как...
Посетитель
small user social cms
Медаль
Сообщений: 435
@gagarin, 10.1 ...

если нет специально заточенных модулей - обновляйтесь до 10.7 (постепенно) это будет значительным + в том числе и по скорости работы сайта
Посетитель
no avatar
Сообщений: 8
Да, да речь идет именно о более поздних модулях.

У более распространенных CMS типа Wordpress или Drupal иногда вылезают критические уязвимости при которых в обязательном порядке нужно обновлять CMS, вот пример https://xakep.ru/2018/04/24/more-patches-for-drupal/ , подобных проблем в данной CMS нет?

Вот именно, что по ощущениям на сайте много кастомных решений и хотелось бы не обновляться, если нет критических багов в этой версии.
Как поднять бабла - мой инструментарий;
GoPR - онлайн-конструктор сайтов ( продается).
Посетитель
small user social cms
Медаль
Сообщений: 435
@gagarin, погонять, потестить, почитать форумы
на некоторые версии были уязвимости, Но можно лекарства
найти
Посетитель
small user social cms
Почетный донор проектаМедальПочетный донор проекта
Сообщений: 196
@gagarin, последние релизы первой ветки прошли независимый аудит безопасности и являются вполне надёжны, сторонние расширения, кроме официальных премиум компонентов от разработчиков системы, аудит не проходили и какие там могут быть проблемы никто не знает, тут только в процессе эксплуатации что-то может выяснится.
Посетитель
no avatar
Сообщений: 8
Спасибо большое, будет учтено!
Как поднять бабла - мой инструментарий;
GoPR - онлайн-конструктор сайтов ( продается).
В начало страницы
Предыдущая темаСледующая тема Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.