Какую версию PHP устанавливать 2.X

 
Посетитель
small user social cms
Медаль
Сообщений: 375
Добрый день!

Есть намерение установить Биллинг пользователей.

1. Установил на сервере дистрибутив InstantCMS v2.12.2, сервер PHP 7.2
Решил проверить соответствие хостинга требованиям разработчика Биллинга, закачав на сайт файл servtest.php

Тест сервер не прошел - ошибка 500
Пришлось понизить версию PHP до значения 5.3 как указано в Требованиях:
Веб-сервер Apache 2 (+ mod_rewrite),
PHP 5.3.x (+ mbstring, iconv, simplexml)
IonCube Loader 4.2.2 (или выше) для PHP 5.3
MySQL 5.x

Однако с такой версией отказался работать дистрибутив 2.12.2 - ошибка 500

Повысив версию до 5.6 пришли к гармонии сервера, файла servtest.php и 2.12.2

При этом Обновление Биллинг пользователей 2.0.5 для InstantCMS 2.12.1+ позволяет выбирать
архив версии PHP (5.6-7.0, 7.1 или 7.2)

Вопрос:
1. Какую версию устанавливать для гармоничной работы всех составляющих?
Возможно требования файла servtest.php устарели?
И установку произвести на PHP-7.2....?
Я Купец и Продавец.ру
Дело Жить
Посетитель
small user social cms
Медаль
Сообщений: 466
Сейчас думаю 7.2 , для нее только надо пару опций включить в настройках сервера
Реклама
cms
Посетитель
small user social cms
Сообщений: 28
А.Саган:

Добрый день!

Есть намерение установить Биллинг пользователей.

1. Установил на сервере дистрибутив InstantCMS v2.12.2, сервер PHP 7.2
Решил проверить соответствие хостинга требованиям разработчика Биллинга, закачав на сайт файл servtest.php

Тест сервер не прошел - ошибка 500
Пришлось понизить версию PHP до значения 5.3 как указано в Требованиях:
Веб-сервер Apache 2 (+ mod_rewrite),
PHP 5.3.x (+ mbstring, iconv, simplexml)
IonCube Loader 4.2.2 (или выше) для PHP 5.3
MySQL 5.x

Однако с такой версией отказался работать дистрибутив 2.12.2 - ошибка 500

Повысив версию до 5.6 пришли к гармонии сервера, файла servtest.php и 2.12.2

При этом Обновление Биллинг пользователей 2.0.5 для InstantCMS 2.12.1+ позволяет выбирать
архив версии PHP (5.6-7.0, 7.1 или 7.2)

Вопрос:
1. Какую версию устанавливать для гармоничной работы всех составляющих?
Возможно требования файла servtest.php устарели?
И установку произвести на PHP-7.2....?

Напиши в поддержку хостинга, мне сделали все так как требуется
Посетитель
small user social cms
Медаль
Сообщений: 375
Александр:

Сейчас думаю 7.2 , для нее только надо пару опций включить в настройках сервера

Подскажите, пожалуйста, какие именно.
Я Купец и Продавец.ру
Дело Жить
Посетитель
small user social cms
Медаль
Сообщений: 375
@RuslanAvtor2018:

А.Саган:



Напиши в поддержку хостинга, мне сделали все так как требуется

Поддержка хостинга мне установила, 5,3 и сказала, что теперь всё соответствует требованиям.
Видимо требования устаревшие, об этом речь...
Я Купец и Продавец.ру
Дело Жить
Посетитель
small user social cms
МедальПочетный донор проекта
Сообщений: 503
на сайте
Если много компонентов не поддерживают 7 , то 5,6 , 7 > производительнее.
Здравствуйте. Спасибо \ пожалуйста.
Посетитель
small user social cms
Медаль
Сообщений: 466
Вы когда чистый инстант устанавливаете он вам показывает все ли нормально, все опции должны быть зелеными , если что то не так то спрашивайте у хостера как это включить для 7.2, для биллинга дополнительно нужно только IonCube Loader включить.

Сторонние компоненты могут глючить на 7.2 , но как правило почти все работает.
Посетитель
small user social cms
МедальПочетный донор проектаАвторитет форумаКубок зрительских симпатийПочетный донор проекта
Сообщений: 1785
А.Саган:
Пришлось понизить версию PHP до значения 5.3 как указано в Требованиях:

shock

https://instantcms.ru/get
Какую версию PHP устанавливать



В админке на главной в виджите показывает что IonCube Loader включен?

Какую версию PHP устанавливать

Александр:
для биллинга дополнительно нужно только IonCube Loader включить.
Если включена, но не "идет" надо спросить у хостера, что бы версия IonCube соответствовала версии PHP.

(Если PHP 7.2, то и IonCube должен быть включен для этой версии).
Редактировалось: 2 раз (Последний: 25 июня 2019 в 11:12)
Посетитель
small user social cms
Медаль
Сообщений: 577
А.Саган:
1. Установил на сервере дистрибутив InstantCMS v2.12.2, сервер PHP 7.2

Я везде ставлю еще пока 5.6 - как наиболее стабильную на данный момент
с php 7, 7.1, 7.2 - какая-то непонятная ситуация ... и слишком часто они выходят
Посетитель
small user social cms
МедальПочетный донор проекта
Сообщений: 503
на сайте
@iKrym:
с php 7, 7.1, 7.2 - какая-то непонятная ситуация ... и слишком часто они выходят
допиливают может
PHP 7.3 выполняет в 3 раза больше запросов в секунду по сравнению с PHP 5.6 , улучшение безопасности .
Редактировалось: 1 раз (Последний: 25 июня 2019 в 12:23)
Здравствуйте. Спасибо \ пожалуйста.
Посетитель
small user social cms
Медаль
Сообщений: 577
@noname:
PHP 7.3 выполняет в 3 раза больше запросов в секунду по сравнению с PHP 5.6 , улучшение безопасности .

да, только это не стабильная версия
и до стаба - ему еще очень далеко.

это как в инстантcms, стабильными были - 1.2.1, 1.6.4, 10.3, 10.7
а промежуточные - часто не работали как надо

сейчас стабильная (почти без косяков) - 2.11 - других не знаю

так и там 5.6 - самая стабильная на сегодняшний день,
и под нее - масса приложений рабочих есть (скриптов)
Посетитель
small user social cms
МедальПочетный донор проекта
Сообщений: 503
на сайте
@iKrym:
так и там 5.6 - самая стабильная на сегодняшний день,
на хостинге PHP 5,6 , 7,1 и есть insta в установщике ) 7.1.30 полет нормальный
Редактировалось: 1 раз (Последний: 25 июня 2019 в 13:00)
Здравствуйте. Спасибо \ пожалуйста.
Посетитель
small user social cms
Медаль
Сообщений: 577
@noname:
на хостинге PHP 5,6 , 7,1 и есть insta в установщике )

Да, и это одна из причин - почему не нужно выбирать 7.1
потому что - если на хостинге 5.6 или 5.5 или 5.4 - система все равно, будет работоспособной
но если на хостинге 7.2 - работать не будет (не всегда будет)
Посетитель
small user social cms
МедальПочетный донор проектаАвторитет форумаКубок зрительских симпатийПочетный донор проекта
Сообщений: 1785
@iKrym:
но если на хостинге 7.2 - работать не будет (не всегда будет)
facepalm
Вы не любите кошек? Да вы просто не умеете их готовить!
))

ЗЫ: Не призываю всех переходить на 7.2, но если есть возможность, почему бы и нет?...
Редактировалось: 2 раз (Последний: 25 июня 2019 в 13:11)
Посетитель
small user social cms
МедальПочетный донор проекта
Сообщений: 503
на сайте
Для устранения уязвимостей рекомендуют 7.1.23 и 7.2.11 и выше .
Здравствуйте. Спасибо \ пожалуйста.
В начало страницы
Предыдущая темаСледующая тема Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.