Ошибки БД при обновлении 2.X

 
Посетитель
small user social cms
Медаль
Сообщений: 157
Обновляюсь в ручном режиме с 2.9, все обновления прошли успешно, но на 2.12.1 выдало ошибку БД:


Ошибка в запросе БД:

Table 'vk.vk2_widgets_bind_pages' doesn't exist
SELECT i.*, w.controller as `controller`, w.name as `name`, wb.*, i.id as `id`
FROM vk2_widgets_bind_pages i
FORCE INDEX (page_id)
INNER JOIN vk2_widgets_bind as wb ON wb.id = i.bind_id
INNER JOIN vk2_widgets as w ON w.id = wb.widget_id
WHERE (i.template = 'default') AND (i.is_enabled = '1') AND (i.page_id IN ('0','1'))
ORDER BY i.page_id, i.position, i.ordering
LIMIT 1000

Последние вызовы:

cmsModel->get() @ /system\controllers\widgets\model.php : 511
modelWidgets->getWidgetsForPages() @ /system\core\core.php : 814
cmsCore->runWidgets() @ /index.php : 49


Повторное обновление ошибку не устранило. Решил накатить 2.12.2 - выдало новую ошибку:


Ошибка в запросе БД:

Table 'vk.vk2_wysiwygs_presets' doesn't exist
SELECT i.*
FROM vk2_wysiwygs_presets i
ORDER BY i.wysiwyg_name
LIMIT 1000

Последние вызовы:

cmsModel->get() @ /system\controllers\wysiwygs\model.php : 30
modelWysiwygs->getPresetsList() @ /system\controllers\admin\forms\form_settings.php : 242
formAdminSettings->{closure}() @ /system\fields\list.php : 110
fieldList->getListItems() @ /system\fields\list.php : 181
fieldList->getInput() @ /templates\default\assets\ui\form_fields.tpl.php : 95
include() @ /templates\default\assets\ui\form.tpl.php : 20
include() @ /system\core\template.php : 2158
cmsTemplate->renderAsset() @ /system\core\template.php : 1855
cmsTemplate->renderForm() @ /templates\default\controllers\admin\settings.tpl.php : 34
include() @ /system\core\template.php : 1743
cmsTemplate->processRender() @ /system\core\template.php : 1706


Интересно, что я делаю не так (всё по инструкции) и почему обновления с 2.9 до 2.12.0 шли без ошибок? Заранее спасибо за помощь!
Посетитель
small user social cms
МедальПочетный донор проекта
Сообщений: 878
"vk.vk2_wysiwygs_presets" сторонний компонент ?
ParadoX:
с 2.9, все обновления прошли успешно, но на 2.12.1 выдало ошибку БД
На 2,12,1 vk.vk2 помер ?
Посетитель
small user social cms
Медаль
Сообщений: 157
Компонент "Wysiwyg редакторы". Родной.
@noname:
На 2,12,1 vk.vk2 помер ?
Скорее наоборот появился?
Редактировалось: 1 раз (Последний: 19 апреля 2020 в 10:37)
В начало страницы
Предыдущая темаСледующая тема Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.