Проблема после обновления mysql 1.X

 
Посетитель
small user social cms
Сообщений: 20
Доброго дня. Может кто подскажет выход из положения.
Сайт на 1.10.4 перестал корректно работать после обновления хостером mysql. В частности загрузка изображений и комментариев.
На запрос к хостеру ответ: Рекомендуем обновить Ваше ПО до совместимого с Mariadb 10.3.
Спасибо
Посетитель
small user social cms
МедальПочетный донор проектаАвторитет форумаКубок зрительских симпатийПочетный донор проекта
Сообщений: 2759
Митяй, поднимите на поддомене пустой сайт на последней 1.10.7
И проверьте загрузку изображений и работу комментариев там.

Почти уверен, что все будет работать. И вам надо просто обновить сайт (и шаблон)
Виджеты, поля и компоненты для instantcms 2 http://www.zau4man.ru/ tm @zau4man
Реклама
cms
Посетитель
small user social cms
МедальАвторитет форумаКубок зрительских симпатийПочетный донор проекта
Сообщений: 3223
Митяй,
Во-первых обязательно сделайте бэкап файлов сайта и базы данных.
Я так понимаю, что править my.cnf хостер не станет ради одного пользователя.
Поэтому включите отладку в админке и попробуйте изображения и комментарии.
Ошибки, если таковые будут - сюда.
Посетитель
small user social cms
Сообщений: 20
Zau4man:

Митяй, поднимите на поддомене пустой сайт на последней 1.10.7
И проверьте загрузку изображений и работу комментариев там.

Почти уверен, что все будет работать. И вам надо просто обновить сайт (и шаблон)

Ок. попробую так.
Посетитель
small user social cms
Сообщений: 20
Ris:

Митяй,
Во-первых обязательно сделайте бэкап файлов сайта и базы данных.
Я так понимаю, что править my.cnf хостер не станет ради одного пользователя.
Поэтому включите отладку в админке и попробуйте изображения и комментарии.
Ошибки, если таковые будут - сюда.

Комменты даже не уходят.
А вот при загрузке фото вот такое вылетает:
Прикрепленные файлы:
20200415143903_h7atr.png | 5.38 Кб | Скачали: 88
Посетитель
small user social cms
Сообщений: 20
Zau4man:

Митяй, поднимите на поддомене пустой сайт на последней 1.10.7
И проверьте загрузку изображений и работу комментариев там.

Почти уверен, что все будет работать. И вам надо просто обновить сайт (и шаблон)

К сожалению, при установке любой с 1.10.5-1.10.7 версии вылетает ошибка при создании базы данных.
Так что походу придется мигрировать на 2-ю. (((
Посетитель
small user social cms
МедальАвторитет форумаКубок зрительских симпатийПочетный донор проекта
Сообщений: 3223
Митяй,
Лучше текст копируйте, а не картинки выкладывайте.
Судя по вашей картинке, всё можно решить достаточно малой кровью.
Умеете пользоваться phpmyadmin ? Если что, спросите техподдержку хостера, как туда попасть.
А дальше, тыкаете в таблицу cms_photo_files - структура - поле hits - изменить (карандаш нарисован) - там поставьте галку Null
Или запросом это можно сделать.
Код SQL:
  1. ALTER TABLE `cms_photo_files` CHANGE `hits` `hits` NULL DEFAULT NULL;
Таких запросов еще будет - сделаете по аналогии.
Митяй:
Так что походу придется мигрировать на 2-ю. (((
Вы замучаетесь мигрировать.
Посетитель
small user social cms
Сообщений: 20
Ris:

А дальше, тыкаете в таблицу cms_photo_files - структура - поле hits - изменить (карандаш нарисован) - там поставьте галку Null
Таких запросов еще будет - сделаете по аналогии.

Вот спасибо за подсказку. Все сработало и по аналогии все исправил, работает.
НО вот с комментариями не получается...
Если сайт запускаю с отладкой, то отправка не происходит.(тупо крутится крутилка на месте) Соответственно и ошибку не показывает.
Если сайт без отладки, то окно коммента закрывается, типо он добавлен. Но сам коммент не появляется.
На хосте в журнале ошибок пишется что коммент добавлен без ошибки.
Как тут ошибку выловить?
Посетитель
small user social cms
МедальАвторитет форумаКубок зрительских симпатийПочетный донор проекта
Сообщений: 3223
Митяй:
Как тут ошибку выловить?
Попробуйте нажать на той странице F12 и попробуйте комметарий. Не появится ли ошибок во вкладке console в панели разработчика?
Если ничего не будет - попросите у хостера логи ошибок (или пусть скажет, где лежат).
Посетитель
small user social cms
Сообщений: 20
Ris:

Если ничего не будет - попросите у хостера логи ошибок (или пусть скажет, где лежат).

В логах на хосте как раз и смотрел, что все норм.
Но по вашей логике заменил в таблице cms_comments Все значения: Null По умолчанию на Null (стояли Нет) и чудо свершилось. Все заработало.
Огромное спасибо вам за подсказку!
Проблема решена.
В начало страницы
Предыдущая темаСледующая тема Перейти на форум: