Повышение версии PHP 7.4 при наличии на сайте премиум компонентов для PHP 5.6 2.X

Как реализовать?

 
Посетитель
small user social cms
МедальПочетный донор проекта
Сообщений: 468
Всех приветствую!

Господа, помогите пожалуйста найти решение - как повысить версию PHP сайта с 5.6 до 7.4 при наличии на сайте премиум компонентов работающих на PHP 5.6?

Решил поменять на всех сайтах PHP с 5.6 (Apache) на 7.4 в режиме FAST CGI (nginx+php-fpm), и удачно перевел сайты на которых не было установлено сторонних компонентов. Остался один сайт, но как реализовать на нем переезд на PHP 7.4 не знаю, так как, на сайте установлены Биллинг пользователей и Инстант видео которые работают на PHP 5.6. Версии компонентов для работы на PHP 7.2+ имеются.

Подскажите по братски, что делать в этой ситуации?
Редактировалось: 1 раз (Последний: 21 января 2021 в 16:13)
Друг друга тяготы носите, и тако исполните закон Христов. Гал.6:2
Посетитель
small user social cms
Кубок зрительских симпатийМедаль
Сообщений: 131
Сделать php 7 какое надо. Взять файлы которые под кубом, из архива премиум компонентов соответствующего версии установленной php 7 и загрузить на сервак. ВСё!
Редактировалось: 1 раз (Последний: 21 января 2021 в 16:21)
работаю теперь здесь bitcoinauto.ru
Реклама
cms
Посетитель
small user social cms
МедальПочетный донор проекта
Сообщений: 468
Сергей:

Сделать php 7 какое надо. Взять файлы которые под кубом, из архива премиум компонентов соответствующего версии установленной php 7 и загрузить на сервак. ВСё!
Я правильно понял - надо только залить из компонента для версии PHP 7 файлы которые под кубом в компонент для PHP 6 и все, этого достаточно?
Друг друга тяготы носите, и тако исполните закон Христов. Гал.6:2
Посетитель
small user social cms
Кубок зрительских симпатийМедаль
Сообщений: 131
Scythian:

Сергей:

Сделать php 7 какое надо. Взять файлы которые под кубом, из архива премиум компонентов соответствующего версии установленной php 7 и загрузить на сервак. ВСё!
Я правильно понял - надо только залить из компонента для версии PHP 7 файлы которые под кубом в компонент для PHP 6 и все, этого достаточно?

Вы пишите: (Версии компонентов для работы на PHP 7.2+ имеются.) Из этих версий компонентов залить кодированные файлы на сервер, где уже версия PHP 5.6 Вами обновлена PHP 7.2+
работаю теперь здесь bitcoinauto.ru
Посетитель
small user social cms
МедальПочетный донор проекта
Сообщений: 468
Сергей:
Вы пишите: (Версии компонентов для работы на PHP 7.2+ имеются.) Из этих версий компонентов залить кодированные файлы на сервер, где уже версия PHP 5.6 Вами обновлена PHP 7.2+

Понял, спасибо за помощь.
Друг друга тяготы носите, и тако исполните закон Христов. Гал.6:2
В начало страницы
Предыдущая темаСледующая тема Перейти на форум: