Проблема с добавлением модулей

 
Sometime CMS Community
Посетитель
no avatar
Сообщений: 12
Добрый день!Есть проблема с добавлением модулей. Пытался добавить несколько модулей, к примеру mod_wrapper, mod_weather, mod_shoutbox. На запрос SQL во всех случаях отвечает: #1054 - Unknown column ’template’ in ’field list’

К примеру запрос

INSERT INTO `cms_modules` (`id`, `position`, `name`, `title`, `is_external`, `content`, `ordering`, `showtitle`, `published`, `user`, `config`, `original`, `css_prefix`, `allow_group`, `cache`, `cachetime`, `cacheint`, `template`) VALUES
(null, ’bottom’, ’wrapper’, ’wrapper’, 1, ’mod_wrapper’, 6, 1, 1, 0, ’’, 1, ’’, -1, 0, 1, ’HOUR’, ’module.tpl’)

Ответ:
#1054 - Unknown column ’template’ in ’field list’

И так на все подобные запросы. В чем может быть проблема, не подскажите? Заранее спасибо!
Модератор
small user social cms
МедальМедаль за отзывчивостьКубок зрительских симпатий
Сообщений: 435
В запросе
INSERT INTO `cms_modules` (`id`, `position`, `name`, `title`, `is_external`, `content`, `ordering`, `showtitle`, `published`, `user`, `config`, `original`, `css_prefix`, `allow_group`, `cache`, `cachetime`, `cacheint`, `template`) VALUES
(null, ’bottom’, ’wrapper’, ’wrapper’, 1, ’mod_wrapper’, 6, 1, 1, 0, ’’, 1, ’’, -1, 0, 1, ’HOUR’, ’module.tpl’)

Кавычки расставлены не верно.
Синтаксис не понятен.
Например id присваивается значение null !!!!?????????

Смотри такой запрос. В phpmyadmin сработал как надо!


INSERT INTO cms_modules (position, name, title, is_external, content, ordering, showtitle, published, user, config, original, css_prefix, allow_group, cache, cachetime, cacheint, template) VALUES
("bottom", "wrapper", "wrapper", 1, "mod_wrapper", 6, 1, 1, 0, "", 1, "", -1, 0, 1, "HOUR", "module.tpl")
Реклама
cms
Sometime CMS Community
Посетитель
no avatar
Сообщений: 12
Александр спасибо! Но к сожалению тоже самое, та же ошибка. Я погуглил - похоже что в таблице нет нужного поля. Но понять какого ума у меня не хватает! smile Что интересно такая хрень со всеми запросами на добавление модулей.
Sometime CMS Community
Посетитель
no avatar
Сообщений: 12
Сейчас вообще полная хрень! В ответ на запрос - #1146 - Table ’host800351_3.cms_modules’ doesn’t exist. Смотрю такой таблицы реально нет. Проверяю сайт все ок, в админке все отображается/редактируется... Что за ерунда...
Sometime CMS Community
Посетитель
no avatar
Медаль
Сообщений: 130
Serg666:

Serg666:
Сейчас вообще полная хрень! В ответ на запрос - #1146 - Table ’host800351_3.cms_modules’ doesn’t exist. Смотрю такой таблицы реально нет. Проверяю сайт все ок, в админке все отображается/редактируется... Что за ерунда...

Таблици cms_modules нету?
Sometime CMS Community
Посетитель
no avatar
Сообщений: 12
koks:
Таблици cms_modules нету?

В том то и фишка с утра была, щас нету! Сайт работает норм, моули нормально отображаются и редактируются. Что за ерунда понять не могу....
Sometime CMS Community
Посетитель
no avatar
Медаль
Сообщений: 130
Код PHP:
  1. CREATE TABLE IF NOT EXISTS `cms_modules` (
  2. `id` int(11) NOT NULL AUTO_INCREMENT,
  3. `position` varchar(10) NOT NULL,
  4. `name` varchar(200) NOT NULL,
  5. `title` varchar(200) NOT NULL,
  6. `is_external` int(11) NOT NULL,
  7. `content` text NOT NULL,
  8. `ordering` int(11) NOT NULL,
  9. `showtitle` int(11) NOT NULL DEFAULT '1',
  10. `published` int(11) NOT NULL DEFAULT '1',
  11. `user` int(11) NOT NULL DEFAULT '1',
  12. `config` text NOT NULL,
  13. `original` int(11) NOT NULL,
  14. `css_prefix` varchar(30) NOT NULL,
  15. `allow_group` int(11) NOT NULL DEFAULT '-1',
  16. `cache` int(11) NOT NULL,
  17. `cachetime` int(11) NOT NULL DEFAULT '1',
  18. `cacheint` varchar(15) NOT NULL DEFAULT 'HOUR',
  19. `template` varchar(35) NOT NULL DEFAULT 'module.tpl',
  20. PRIMARY KEY (`id`)
  21. ) ENGINE=MyISAM DEFAULT CHARSET=cp1251 AUTO_INCREMENT=0 ;
создай
Sometime CMS Community
Посетитель
no avatar
Сообщений: 12
Добавил! Ситуация интересная. Таблица появилась, но пустая. Выполнил один из запросов для добавления модуля

INSERT INTO `cms_modules` (`id`, `position`, `name`, `title`, `is_external`, `content`, `ordering`, `showtitle`, `published`, `user`, `config`, `original`, `css_prefix`, `allow_group`, `cache`, `cachetime`, `cacheint`, `template`) VALUES
(null, ’bottom’, ’wrapper’, ’wrapper’, 1, ’mod_wrapper’, 6, 1, 1, 0, ’’, 1, ’’, -1, 0, 1, ’HOUR’, ’module.tpl’)

В таблице появилась одна эта строчка с этим модулем. В админке ничего не изменилось - как не видел модуля, та и не видел. Все остальные модули добавляются/редактируются на ура. Такое чувство, что я редактирую одну базу, а ЦМС ссылается на другую. на всякий случай перепроверил, и в админке и в config.inc.php база правильная. Могут модули ссылаться на какую то другую таблицу???
Sometime CMS Community
Посетитель
no avatar
Сообщений: 12
Ребят помогите, чувствую себя идиотом! Решил сделать копию проблемного сайта. Ну чтобы ковыряться не мешая пользователям и играться все таки с копией БД, а не с реальной. Вариант с денвером не очень устраивает по некоторым причинам. Так вот! На хост аккаунте 4 сайта и 5 БД. Понятно что одна лишняя, тестовая так сказать. Значить делаю копию БД сайта и заливаю в эту базу данных, предварительно удалив в ней все таблицы. Копию делаю и заливаю через Экспорт/Импорт в "MaiAdmin". Делаю копию сайта с ФТП и заливаю ее на созданный суб домен, в config.inc.php меняю название базы на нужное мне. Запускаю и офигиваю т.к. вижу контент сайта который делал в этой базе полгода назад тоже на инстанте. Решил перезалить базу средствами самой ЦМС. На рабочем сайте делаю бэкап базы, на сайте клоне также через ЦМС импортирую его. Тоже самое - чужой сайт. Захожу в БД, удаляю все таблицы, захожу на сайт - сайту хоть бы хны. Прекрасно работает. Пробую копированием баз в "MaiAdmin" - та же хрень. База прописана правильная - раз сто поверил. Вот сижу и не знаю что и думать. Хостеру написать, но ведь даже спросить не знаю что, на бред похоже, нельзя убить БД, а сайт работает как не в чем не бывало. Но факт фактом....
Редактировалось: 1 раз (Последний: 24 июня 2010 в 15:55)
InstantCMS Team
small user social cms
МедальКубок зрительских симпатийАвторитет форумаПатриот InstantCMS ;-)
Сообщений: 3129
Serg666, прочитал наскорую - не забываем про кеши всего - сайтов и браузера...
Зарабатываю здесь - Хостинг здесь - Жить в обществе и быть свободным от общества нельзя!...
Sometime CMS Community
Посетитель
no avatar
Сообщений: 12
Madmax, Добрый день! Это я первым делом проверил - ОК! Что характерно, когда сайту-клону подключаешь рабочаю БД все ок.
В начало страницы
Предыдущая темаСледующая тема Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.