Не открываются линки

Линки второго уровня не открываются

 
Sometime CMS Community
Посетитель
no avatar
Сообщений: 7
Люди,<br/>посоветуйте кто знает.<br/>1. У меня не открываются линки второго уровня. Выдаётся ошибка 404 <br/>2. Сайт открывается только при добавлении /index.php<br/>http://demo1264.fc-host23.de/index.php
Посетитель
small user social cms
Медаль
Сообщений: 359
Добавь в файл .htaccess в корне сайта вот такую строчку<br/>DirectoryIndex index.php<br/>Если она уже есть, значит убери файл index.html или index.htm из корня сайта v
Реклама
cms
Sometime CMS Community
Посетитель
no avatar
Сообщений: 33
Alex:
<br/>Люди,<br/>посоветуйте кто знает.<br/>1. У меня не открываются линки второго уровня. Выдаётся ошибка 404 <br/>2. Сайт открывается только при добавлении /index.php<br/>http://demo1264.fc-host23.de/index.php<br/>
<br/>Скорее всего опроблема на самом хосте. Это моё мнение ... <br/>Попробуй заменить свой файл .htaccess на хосте на тот который находится в самом движке который ты скачал ... <br/>Иногда они просто не копируются коректно .. У меня такая проблема тоже была ! <br/>
Sometime CMS Community
Посетитель
no avatar
Сообщений: 7
Спасибо за советы<br/>с помощью совет Захара исправил к сожалению только вторую проблему (показ страницы) <br/>Первая (линки второго уровня выдают ошибку 404) осталась без изменений. Пробовал переписать файл .htaccess не помогло. Также сменил хост не помогает. <br/>Подскажите кто что может.<br/>Alex
Посетитель
small user social cms
Медаль
Сообщений: 359
Alex:
<br/>Спасибо за советы<br/>с помощью совет Захара исправил к сожалению только вторую проблему (показ страницы) <br/>Первая (линки второго уровня выдают ошибку 404) осталась без изменений. Пробовал переписать файл .htaccess не помогло. Также сменил хост не помогает. <br/>Подскажите кто что может.<br/>Alex<br/>
<br/>Дружище, я зашёл к тебе на сайт, всё работает. Что ты называешь линками второго уровня? Может я что то не понял?
Sometime CMS Community
Посетитель
no avatar
Сообщений: 33
Всё работает ! Почистий кеш в броузере !
Sometime CMS Community
Посетитель
no avatar
Сообщений: 6
Первый раз пробую себя в сайтах, подскажите плз<br/>У меня такая же беда... главная страница пашет, а ссылки нет<br/>http://93.190.200.225/<br/>что в этой теме писали, я вроде сделал, но так и не заработало
Sometime CMS Community
Посетитель
no avatar
Сообщений: 6
anklav:
<br/>Первый раз пробую себя в сайтах, подскажите плз<br/>У меня такая же беда... главная страница пашет, а ссылки нет<br/>http://93.190.200.225/<br/>что в этой теме писали, я вроде сделал, но так и не заработало<br/>
<br/>ммм... не получается. <br/>уже установил версию свежую инстанта, устанавливается без проблем, после установки удаляю папки инстал и миграте согласно инструкции, но видна только главная страница, в админке никаких проблем нет, документы создаются легко... по всем ссылкам гуляю всё вижу.<br/>На самом сайте, например в пункте "Регистрация" при просмотре ссылки - http://93.190.200.225/registration<br/>но папки "registration" на сервере нет, также как и папки "content", данные папки находятся на сервере в папке srv/www/htdocs/components<br/>Единственное что сервер поднят не на винда+денвер, а на линуксе, но это не должно влиять<br/>Что не так, подскажите плз
Sometime CMS Community
Посетитель
no avatar
Сообщений: 88
anklav<br/>Вероятно у вас на сервере не включен mod rewrite. Я тоже пытался на локалке ставить, на TopServer, не стало, хотя в конфиге апача модуль подключен. <br/>
Sometime CMS Community
Посетитель
no avatar
Сообщений: 6
это сервак с внешним ай-пи, ставил на него joomla - работает без проблем пример тут: http://93.190.200.225/test/
Sometime CMS Community
Посетитель
no avatar
Сообщений: 84
Joomla у вас работает потому, что в настройках отключено использование SEF и mod_rewrite. По той же причине работает и админка InstantCMS.<br/>Обратите внимание на внешний вид ссылок:<br/>Joomla:<br/>http://93.190.200.225/test/index.php?option=com_autostand&Itemid=3<br/>InstantCMS:<br/>http://93.190.200.225/view-forum/menuid-41<br/>У вас 100% проблемы в настройках сервера. Ищите решение именно там
Sometime CMS Community
Посетитель
no avatar
Сообщений: 88
anklav у вас и джумла работает только с ссылками вида index.php?option=com_user&view=remind для которых модреврайт не нужен. а ссылки вида сайт.com/catalog/23/6 работать не будут. кстати на сайте вашем поиск видите работает? http://93.190.200.225/index.php?view=search&query=&gosearch.x=13&gosearch.y=11 и посмотрите какой адрес у нее.<br/> glasses чуток опаздал с ответом
Редактировалось: 1 раз (Последний: 6 февраля 2009 в 18:51)
Sometime CMS Community
Посетитель
no avatar
Сообщений: 84
smile
Sometime CMS Community
Посетитель
no avatar
Сообщений: 6
дак я понимаю что проблема у меня 8) просто в виду своей неопытности некоторых вещей не знаю...<br/>Щас буду разбираться, если что то с меня парни вам по плюсю 8) пасиба большое
Sometime CMS Community
Посетитель
no avatar
Сообщений: 6
нифига не получается пока...<br/>Нашел где в настройках апача подключается mod_rewrite, подключил его, апач рестартнул, но эффекта ноль<br/>вопрос: Почему на сайте работает поиск, а остальные ссылки нет?<br/>продолжаю мучаться )<br/>
Редактировалось: 1 раз (Последний: 7 февраля 2009 в 00:12)
В начало страницы
Предыдущая темаСледующая тема Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.