maps и php7

InstantCMS 2.X
#1 28 января 2018 в 13:30
разработчики подскажите пожалуйста планируется ли переход мапса на php7? установил php7 и вот такая ошибка
PHP Fatal error: The file /public_html/system/controllers/places/frontend.php was encoded by the ionCube Encoder for PHP 5.3 and cannot run under PHP 7.0.
Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 5.6. in Unknown on line 0
#2 28 января 2018 в 17:50
Не совсем понимаю еще как это все работает, но у меня вот так вот работает maps



Вот в админке пишет


Одна беда. Насколько помню ключи для https и http разные должны быть. На https сайт нихрена не работает — "Неверный ключ InstantMaps".
Непонятно по выходным работают или нет разработчики… Сукти ответа нет… У меня ломка уже.
#3 28 января 2018 в 23:28
А вот биллинг только что взял

Fatal error: The file /var/www/site/data/www/site.ru/system/controllers/billing/backend.php was encoded by the ionCube Encoder for PHP 5.3 and cannot run under PHP 7.0. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 5.6. in Unknown on line 0

xD
#4 28 января 2018 в 23:35
Не знаю ангийского ни разу, но что-то мне подсказывает, что ошибка, потому что ioncube старой версии для php 5.6. Видимо, для php7 нужна другая версия ioncube encoder.
#5 29 января 2018 в 04:45

А вот биллинг только что взял

Dmitry

ionCube Encoder for PHP 5.3 and cannot run under PHP 7.0.

vsemkrot
Закодировано только под php5, под php7 еще не перезазендили. просите саппорт обновить файлы под версию 7
#6 29 января 2018 в 10:58


А вот биллинг только что взял

Fatal error: The file /var/www/site/data/www/site.ru/system/controllers/billing/backend.php was encoded by the ionCube Encoder for PHP 5.3 and cannot run under PHP 7.0. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 5.6. in Unknown on line 0

xD

Dmitry
Скажите пожалуйста потом к какому решению пришли
#7 29 января 2018 в 11:04
На 5.6 работает стабильно мапс, видео
ошибка у вас в ionCube Encoder

ищите поиском в сети ioncube Install для вашей версии операционной системы
#8 29 января 2018 в 11:12

Скажите пожалуйста потом к какому решению пришли

@alexandr22
Переключил php для этого сайта с 7-ой верссии на 5.6.
#9 29 января 2018 в 11:31

ошибка у вас в ionCube Encoder

@ivanpolyakov
На соседнем сайте на php5.6 видео, мапс и биллинг работают без проблем. Проблема именно с 7.0.
#10 29 января 2018 в 12:48
Dmitry, @ivanpolyakov, вы боты??? Вам выше ответ написан, чего еще хотите?

Закодировано только под php5, под php7 еще не перезазендили. просите саппорт обновить файлы под версию 7
#11 29 января 2018 в 15:03

просите саппорт обновить файлы под версию

kirkr
Не об этом ли речь...

Проблема именно с 7.0.

Dmitry
#12 8 октября 2018 в 20:50
Тема давняя, но изменилась ли ситуация в данный момент или с 7 версией никак?
#13 9 октября 2018 в 13:06
Давайте все вместе позовем!!! Дядюшка Биллинг и девушка Maps в версии PHP 7 покажись для нас!!!
#14 19 октября 2018 в 23:12
Новостей нет?
Написал разработчику…
#15 20 октября 2018 в 19:42
Компонент получен.
PHP 7.2 (Apache-PHP-7) работает без проблем.

В очередной раз слухи о бесследном исчезновении R2, оказались такими, что несколько не соответствуют действительности))
Вы не можете отвечать в этой теме.
Войдите или зарегистрируйтесь, чтобы писать на форуме.

Похожие темы

Используя этот сайт, вы соглашаетесь с тем, что мы используем файлы cookie.