Неверный путь картинок

в пути к картинке добавляется директория

 
Посетитель
small user social cms
Медаль
Сообщений: 455
Зашел в тупик. Сайт на iCMS 2 локально работает нормально, но при переводе его на хостинг вылезает странная вещь. Главная страница в порядке, а во вложенных не отображаются картинки, которые расположены в папке upload (они там 100% есть).
выдается на картинки другой путь вместо сайт.ру/upload/...(где и лежит картинка) - присваивается сайт.ру/article/upload/...
Подскажите где собака зарыта.
Прикрепленные файлы:
20151128232012GoogleChrome_5l9i6.png | 103.07 Кб | Скачали: 221
Чистить кэш, исправлять базу ручками и искать в гугле умею. Если задаю вопрос, то значит есть существенная причина!!!
Посетитель
small user social cms
МедальПочетный донор проектаАвторитет форумаКубок зрительских симпатийПочетный донор проекта
Сообщений: 2537
Вооооооооооот. У меня такая же фигня.
Пришлось ставить инстант с нуля. Благо правки были только с виджетами и меню.
Виджеты, поля и компоненты для instantcms 2 http://www.zau4man.ru/
Реклама
cms
Посетитель
small user social cms
МедальПочетный донор проектаАвторитет форумаКубок зрительских симпатийПочетный донор проекта
Сообщений: 2537
Если открыть исходный код страницы, и в src картинки добавить слеш перед адресом картинки, картинка покажется.

Ощущение, что появилось в новой версии. Так как раньше я несколько раз переносил сайты с денвера в интернет, и все было ок...
Редактировалось: 1 раз (Последний: 28 ноября 2015 в 16:32)
Виджеты, поля и компоненты для instantcms 2 http://www.zau4man.ru/
Посетитель
small user social cms
Медаль
Сообщений: 455
Быстрый ответ это супер.. но перспектива отсутствия решения как то пугает... версию использую одну и туже.. переносил уже не один сайт - такое впервые.
Чистить кэш, исправлять базу ручками и искать в гугле умею. Если задаю вопрос, то значит есть существенная причина!!!
Посетитель
small user social cms
Медаль
Сообщений: 455
Вот я невнимательный... решение нашел. в конфиге если в параметре 'host' в конце ссылки добавить слеш - то выходит такая проблема. Убираем слеш и всё ОК.
Чистить кэш, исправлять базу ручками и искать в гугле умею. Если задаю вопрос, то значит есть существенная причина!!!
В начало страницы
Предыдущая темаСледующая тема Перейти на форум: