PHP 5.3 vs PHP 5.4 Debian

 
Посетитель
small user social cms
Сообщений: 80
Друзья. Подскажите пожалуйста. У меня такой вопрос

Арендую сервер достаточно давно и там у меня старая версия Debian и кучу сайтов на Инстанте в том числе на первой ветке.
Новый Инстант требует версию PHP от 5.4 что бы ее поставить необходимо обновить Debian. Саппорт хостера предупреждает и спрашивает о совместимости имеющихся на сервере сайтов. На сервере сайты практически все на Инстанте двух версий. Совместимы ли старые версии Инстанта с php 5.4? С какими еще трудностями я могу столкнуться? Заранее всем огромное спасибо!
InstantCMS Team
small user social cms
МедальАвторитет форумаКубок зрительских симпатий
Сообщений: 4361
yakrutov:
Совместимы ли старые версии Инстанта с php 5.4
да
Видео каталог для InstantCMS | Аудио каталог для InstantCMS | Мы Вконтакте | Предложение для спонсоров
Посетитель
small user social cms
МедальАвторитет форумаКубок зрительских симпатийПочетный донор проекта
Сообщений: 2644
yakrutov,
Имею два сайта на инстанте.
Один на версии 1.9, другой на второй ветке.
После выхода версии 2.8.0 написал запрос в техподдержку хостера и мне за небольшую денежку обновили php до 5.6 и mysql до 5.7.
Новый майэскуэль сразу отказался работать с инстантом (очень строгий в group_by), но сотрудники хостера сразу его настроили и теперь он работает нормально.
Новый php нормально работает со второй веткой и отказывается работать с версией 1.9. Выдает ошибку по поводу _construct в классах.
Переделал _construct в нескольких файлах и теперь все работает нормально.
Посмотрите в файлах readme установочных пакетов, какие версии php они поддерживают.
Если версия 5.4 не поддерживается - могут возникнуть вышеупомянутые проблемы, но они легко устраняются.
Редактировалось: 1 раз (Последний: 17 августа 2017 в 19:19)
В начало страницы
Предыдущая темаСледующая тема Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.