Проблема при подключении JS скриптов 1.X

 
Посетитель
no avatar
Сообщений: 3
Добрый день, уважаемые участники форума. Столкнулся со следующей проблемой:

В файле .tpl подключаю JS скрипты:
Код PHP:
  1. {add_js file="templates/main/js/bootstrap-table.js"}
  2. {add_js file="components/imet/js/compatibility.js"}
При загрузке страницы в инспекторе объектов в браузере скрипты загружены:
Код HTML:
  1. <script type="text/javascript" src="/templates/main/js/bootstrap-table.js"></script>
  2. <script type="text/javascript" src="/components/imet/js/compatibility.js"></script>
Когда я пытаюсь использовать функцию из bootstrap-table.js:
Код PHP:
  1. $('#side-effect-table').bootstrapTable('destroy');
то вылетает ошибка:
$(...).bootstrapTable is not a function

Если я пропишу скрипт в общем файле template.php, то тогда всё работает. Но мне надо подключить только в одном. Может кто-нибудь знает, в чём дело или хотя бы в какую сторону копать? Заранее спасибо
Редактировалось: 3 раз (Последний: 31 января 2018 в 17:12)
Посетитель
small user social cms
МедальАвторитет форумаПочетный донор проектаКубок зрительских симпатий
Сообщений: 3093
А модулем их там нельзя подключить? что бы не через .tpl
Реклама
cms
Посетитель
no avatar
Сообщений: 3
Jestik:

А модулем их там нельзя подключить? что бы не через .tpl

Это надо делать в файле frontend.php?
Посетитель
small user social cms
МедальАвторитет форумаПочетный донор проектаКубок зрительских симпатий
Сообщений: 3093
@niki, ну как я понял у вас 1 ветка, в модуле просто подключить скрипты а модуль вывести на нужной странице. Не факт что так можно...
Посетитель
small user social cms
МедальАвторитет форума
Сообщений: 1545
Скорее всего дело в очерёдности подключения.
Посетитель
no avatar
Сообщений: 3
Lora:

Скорее всего дело в очерёдности подключения.

Очередность менял, не помогло
В начало страницы
Предыдущая темаСледующая тема Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.