olegan

olegan

+34
Репутация
73
Рейтинг
#1 Не работает InstantMaps 31 августа 2021 в 16:33

Перестали добавляться объекты в InstantCMS v2.13.1 и InstantMaps 2.0.7 выдает вверху страницы ошибку Notice: Undefined index: id in /home/..www/system/controllers/places/hooks/content_places_form.php on line 0  и при попытке выбрать адрес замирает полностью все. 

#2 Не добавить объект в InstantMaps 2 24 августа 2021 в 17:40

Перестали добавляться объекты в InstantCMS v2.13.1 и InstantMaps 2.0.7 выдает вверху страницы ошибку Notice: Undefined index: id in /home/..www/system/controllers/places/hooks/content_places_form.php on line 0  и при попытке выбрать адрес замирает полностью все. Именно при адресе.все остальное можно выбрать, и категории и фото. В чем может быть проблема?

#3 InstantMaps 2 - проблемы и их решения 10 августа 2021 в 09:59

Не устанавливается картинка категории на ICMS 2.13.1., версия компонента 2.0.7. Загружается, при редактировании выводится, а на сайте стандартные папки.

#4 InstantMaps 2 - проблемы и их решения 1 августа 2021 в 12:04

Не работает смена владельца в InstantMaps. Кнопка Выбрать не открывает ничего, а при ручной вставке нового владельца не сохраняется. Версия системы v2.13.1 версия InstantMaps 2.0.7

#5 [ЕСТЬ РЕШЕНИЕ] Проблема с фотоальбомом 21 июня 2021 в 14:45


В консоли у Вас ошибка: Failed to load resource: the server responded with a status of 403 (Forbidden),

  1. var LANG_PHOTOS_DELETE_PHOTO_CONFIRM = 'Удалить эту фотографию?'; icms.photos.row_height = '256';
в нетворк какая-то фигня с styles.css .

@noname

Спасибо.Один удар по клавиатуре и все заработало (раньше так чинили телевизоры).Тема опять закрывается.
#6 [ЕСТЬ РЕШЕНИЕ] Проблема с фотоальбомом 21 июня 2021 в 09:32


Если на этом хостинге есть проблемы с одним Типом контента или компонентом изначально, то ~

возможно лучше сменить хостинг ?

@noname
или для инсты использовать другой

@noname
На нем нормально работает сайт с версией v2.13.1 и 2.14.2(обновленный с 2.14.1). Никаких проблем никогда не было.А вот с новым какая-та фигня именно с фотоальбомом.Думаю, что проблема не в настройках хостинга.
#7 [ЕСТЬ РЕШЕНИЕ] Проблема с фотоальбомом 21 июня 2021 в 09:24


Опять или всё то же?

Lora
Там вроде на компе работало, а при переносе или новой установке нет и по идее на бегет.
olegan почитайте отзывы про бегет от пользователей instantcms, возможно лучше сменить хостинг ?

@noname
Хостинг на hostland.ru.Там рано закрыл тему.При переустановке компонент фотоальбомы вообще перестал настраиваться и работать.
#1 [ЕСТЬ РЕШЕНИЕ] Проблема с фотоальбомом 20 июня 2021 в 19:47
Версия 2.14.2, установка с "нуля". При попытке настроить компонент ФОТОАЛЬБОМ выходит ошибка

Fatal error: Uncaught ArgumentCountError: Too few arguments to function actionAdminControllersEdit::run(), 0 passed in /home//system/core/controller.php on line 605 and exactly 1 expected in /home/system/controllers/admin/actions/controllers_edit.php:5 Stack trace: #0 /home//system/core/controller.php(605): actionAdminControllersEdit->run() #1 /home//system/core/action.php(45): cmsController->runExternalAction('controllers_edi...', Array) #2 /home//system/controllers/admin/actions/controllers.php(9): cmsAction->__call('runExternalActi...', Array) #3 /home//system/core/controller.php(605): actionAdminControllers->run('edit') #4 /home//system/core/controller.php(476): cmsController->runExternalAction('controllers', Array) #5 /home//htd in /home//system/controllers/admin/actions/controllers_edit.php on line 5
Альбомы создаются, а фото не грузятся-перебрасывает на Главную страницу, при попытке посмотреть фото в виджете, тоже выбрасывает на Главную.Файлы уже смержил, расхождений с дефолтом нет.Ошибка на всех шаблонах.
И странный вывод фотографий, сбит вывод фильтра и фото выводятся в столбик.Посмотреть на сайте
#9 [ЕСТЬ РЕШЕНИЕ] Проблема с редактированием компонента. 8 июня 2021 в 09:06


Чтобы переустановить нужно стереть БД или создать новую, смотрите чтобы архив был в норме и распаковывался верно. А если что-то не так с хостингом, то имхо лучше разобраться сейчас… Можно на панели управления и шаблоне дефолт проверить. Какой режим апач, cgi, fastcgi ?

@noname

Базу стирал, не пробовал только создать новую, попробую.По остальному сказать ничего не могу.Только это "Данный домен работает в обычном режиме модуля php,CGI режим отключен."Тему закрываю.Вам спасибо за советы.
#10 [ЕСТЬ РЕШЕНИЕ] Проблема с редактированием компонента. 7 июня 2021 в 20:43


Попробуйте на хосте поставить выше 7.1. Например 7.3

Lora
Не помогло.В принципе, ошибка не сильно критичная, все остальное работает нормально, по крайне мере, пока косяков явных не обнаружилось.Может потом, при добавлении компонентов или полей появятся, но пока нет.Пока тему не закрываю.может еще идеи появятся.
#13 [ЕСТЬ РЕШЕНИЕ] Проблема с редактированием компонента. 7 июня 2021 в 17:45


olegan,
Переустановите заново.
Просто наберите вашсайт.ру/install и повторите установку.
Что-то в базу данных не записалось у вас...

Ris
Странности продолжаются.Установил с нуля, ошибка та же самая.Установил на локалку, все нормально работает, перенес с локалки на сервер-эта же ошибка! Причем, через Контент-фотоальбом-настройки-настройка компонента, настройки открываются и работают, а через компоненты-фотоальбомы нет.Что можете еще посоветовать?
#1 [ЕСТЬ РЕШЕНИЕ] Проблема с редактированием компонента. 6 июня 2021 в 16:08
Установил с нуля версию 2.14.2 (с демоданными), вроде бы все прошло нормально, только фот в админке при попытке настроить компонент ФОТОАЛЬБОМЫ, выбрасывает ошибку
Fatal error: Uncaught ArgumentCountError: Too few arguments to function actionAdminControllersEdit::run(), 0 passed in /home/сайт/htdocs/www/system/core/controller.php on line 605 and exactly 1 expected in /home/сайт/htdocs/www/system/controllers/admin/actions/controllers_edit.php:5 Stack trace: #0 /home/сайт/htdocs/www/system/core/controller.php(605): actionAdminControllersEdit->run() #1 /home/сайт/htdocs/www/system/core/action.php(45): cmsController->runExternalAction('controllers_edi...', Array) #2 /home/сайт/htdocs/www/system/controllers/admin/actions/controllers.php(9): cmsAction->__call('runExternalActi...', Array) #3 /home/сайт/htdocs/www/system/core/controller.php(605): actionAdminControllers->run('edit') #4 /home/сайт/htdocs/www/system/core/controller.php(476): cmsController->runExternalAction('controllers', Array) #5 /home/сайт/htd in /homeсайт/htdocs/www/system/controllers/admin/actions/controllers_edit.php on line 5
Настройки всех остальных компонентов открываются нормально.На сайте все работает нормально, альбомы создаются и фото добавляются, а в админке глюк.
Подскажите, что делать?
Используя этот сайт, вы соглашаетесь с тем, что мы используем файлы cookie.